Выводить отсортированными по алфавиту не получается...

Форум 1С: Одинэс.Ру

Найти!

Выводить отсортированными по алфавиту не получается...

deefm
23.04.2009 - 04:50
Здравствуйте, подскажите пож-та, как сделать, чтобы контрагенты, при выводе в печатную форму, были отсортированы по алфавиту. Я перебираю документы (шапку и табличную часть), в результате, они выводятся, отсортированными по реквизиту ДатаРег.
Предполагаю, что надо сначала выгрузить в ТаблицуЗначений, в ней уже отсортировать и затем выводить. Может быть можно как-нибудь по-другому?
Вот мой текст:
 
Процедура Сформировать()  
 
Док = СоздатьОбъект("Документ.Договор");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл  
Если (Док.ДатаРег>=НачДата) И (Док.ДатаРег<=КонДата) Тогда
 
Таб.ВывестиСекцию("Договор");  
 
Если Док.КоличествоСтрок()>0 Тогда
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
 
Таб.ВывестиСекцию("Строки");
 
КонецЦикла;
КонецЕсли;
 
КонецЕсли;
КонецЦикла;  
 
КонецПроцедуры
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 02:48
Смотри также:
Выводить отсортированными по алфавиту не получается...
Как быстро программно изменить родителя n-го числа элементов ? в 7.7
Надо преобразовать "18 Февраля 2009" в Дату

Re: Выводить отсортированными по алфавиту не получается...

jurii
12 - 23.04.2009 - 05:31
(8) А так?
"//{{ЗАПРОС(Сформировать)
|Обрабатывать НеПомеченныеНаУдаление;
|ДатаРег = Документ.Договор.ДатаРег;
|Исполнитель = Документ.Договор.Исполнитель;
|Группировка Исполнитель упорядочить по Исполнитель.Наименование;
|Группировка ДатаРег;
|Условие((ДатаРег >= ВыбНачПериода) И (ДатаРег <= ВыбКонПериода));
|"//}}ЗАПРОС
Только группировки исправь на 2: "Исполнитель" и "ДатаРег"

Re: Выводить отсортированными по алфавиту не получается...

deefm
13 - 23.04.2009 - 06:03
Всем СПАСИБО!!! Запрос получается, только при выводе в печатной форме между секциями оставляет пустую строку. Т.е. сейчас выводит в виде:
 
Гранат
01.01.09   №12   1000  примечание
01.03.09   №13   1500  доп.соглашение
 
Пегас
02.02.09   №22   5000 примечание
01.03.09   №23   6000 доп.соглашение
 

А мне надо, чтобы выводил в виде:
 
Гранат
01.01.09   №12   1000  примечание
01.03.09   №13   1500  доп.соглашение
Пегас
02.02.09   №22   5000 примечание
01.03.09   №23   6000 доп.соглашение
 

Вот мой запрос:
 
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
 
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Обрабатывать НеПомеченныеНаУдаление;
|тДок = Документ.Договор.ТекущийДокумент;
|Контрагент = Документ.Договор.Исполнитель;
|ДатаРег = Документ.Договор.ДатаРег;
|Условие ((ДатаРег>=НачДата) И (ДатаРег<=КонДата));
|Группировка Контрагент Упорядочить По Контрагент.Наименование без групп;
|Группировка тДок;";
 
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;  
 
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
 
Пока Запрос.Группировка("Контрагент") = 1 Цикл
 
Таб.ВывестиСекцию("Договор");
 
Пока Запрос.Группировка("тДок") = 1 Цикл
Док = Запрос.тДок;
 
Таб.ВывестиСекцию("Док");
 
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл  
 
Таб.ВывестиСекцию("Стр");
 
КонецЦикла;        
 
КонецЦикла;
КонецЦикла;
 
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры
 

Re: Выводить отсортированными по алфавиту не получается...

deefm
14 - 23.04.2009 - 06:04
(+13)Секции в конфигураторе идут подряд, т.е. пустых строчек между ними - нет.

Re: Выводить отсортированными по алфавиту не получается...

deefm
15 - 23.04.2009 - 08:54
+(13) Чтобы было нагляднее, выкладываю картинками...
Вот, как у меня секции в конфигураторе:
http://s49.radikal.ru/i125/0904/de/883f77a84a86.jpg
 
Сейчас выводится вот так:
http://i046.radikal.ru/0904/56/51274125e45e.jpg
 
А надо, чтобы выводилось так:
http://i028.radikal.ru/0904/88/c7d74800ec05.jpg
 

Re: Выводить отсортированными по алфавиту не получается...

deefm
16 - 23.04.2009 - 09:49
?

Интересные темы

odines.ru
20.10.2020 - 02:48
Смотри также:
Срочно нужен консультант по 1С _77 Бухгалтерия бюджетного предприятия
Универсал 2.7
как обновить отчетность за 2 кв. 2009?

Re: Выводить отсортированными по алфавиту не получается...

Гуня
17 - 23.04.2009 - 09:52
что в секции СТр содержится?

Re: Выводить отсортированными по алфавиту не получается...

Гуня
18 - 23.04.2009 - 10:00
(17) звиняюсь, просмотрел 1 скрин. У тебя секция Договор из двух строк состоит. убери одну пустую

Re: Выводить отсортированными по алфавиту не получается...

Гуня
19 - 23.04.2009 - 10:01
Зачем секция СТр мне непонятно. Она всеравно не выводится

Re: Выводить отсортированными по алфавиту не получается...

deefm
20 - 23.04.2009 - 10:01
(18) Спасибо, что-то совсем заработалась... ))

Re: Выводить отсортированными по алфавиту не получается...

Uho
21 - 23.04.2009 - 11:22
20-deefm >заработалась... ))
ну с этого и надо было начинать)))
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Как начислить аванс с возвратов? Хелп! Перестала работать "Выгрузить данные" »
© 2009 Форум 1С: Одинэс.Ру