Не могу получить табличную часть документа-основания.

Форум 1С: Одинэс.Ру

Найти!

Не могу получить табличную часть документа-основания.

Rajva1
20.03.2009 - 04:18
Помогите со счет-фактурой. Надо переделать немного… и вот в чем загвоздка. Берем стандартную внешнюю печатную обработку sf2006 и в процедуру ПриОткрытии вносим небольшие изменения.
 
Докум.ДокОснование.ВыбратьСтроки();
если Докум.ДокОснование.ПолучитьСтроку()=1 тогда
если найти(строка(Докум.ДокОснование.Номенклатура),"Услуга")<>0 тогда
услуга=1;
Иначе
услуга=0;
КонецЕсли;
КонецЕсли;
 
Все красиво Докум=счетфактура, Докум.ДокОснование=реализация, Докум.ДокОснование.ПолучитьСтроку()=1, а дальше фигня… Докум.ДокОснование.Номенклатура="" и вообще в отладчике не видно ни одного строчного реквизита документа-основания…
 
А если сделать вот так
 
Докум.ДокОснование.ВыбратьСтроки();
Пока Докум.ДокОснование.ПолучитьСтроку()=1 цикл
если найти(строка(Докум.ДокОснование.Номенклатура),"Услуга")<>0 тогда
услуга=1;
Иначе
услуга=0;
КонецЕсли;
КонецЦикла;
 
То на цикле вообще происходит зацикливание, как будто в документе бесконечно строк… хотя тот же отладчик выдает Докум.ДокОснование.КоличествоСтро()=1
 
Где подвох?
К списку тем К списку форумов

Интересные темы

odines.ru
25.10.2020 - 20:12
Смотри также:
Как из 1С обратиться к странице Интернета?
Помогите с расходами в УСН, не пойму как они признаются
Доступ к контекту сформированной таблицы

Re: Не могу получить табличную часть документа-основания.

roma n
1 - 20.03.2009 - 04:39
Работай с объектом, созданным функцией СоздатьОбъект()

Re: Не могу получить табличную часть документа-основания.

Rajva1
2 - 20.03.2009 - 04:46
Все получилось. Спасибо.
Вот ведь грабли...
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Сохранить документ ворд как веб страницу Разные результаты запроса в SQL и DBF »
© 2009 Форум 1С: Одинэс.Ру