Можно ли восстановить базу (хотя бы протелепатируйте)

Форум 1С: Одинэс.Ру

Найти!

Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
27.07.2009 - 06:43
После неправильной синхронизации жестких дисков в рейде cлетела база 1сУсл+Пр-во+Бух. Слетели файлы 1sentry 1sbkttl 1saccsel. После тестирования и исправления база стала отвечать, но пропали все проводки. Групповая обработка док-ток проводит не все и ругается на ошибку при вып глобального модуля. Это кабздец или что-то можно накопать? Бэкапов и архивов нет.
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
21.10.2020 - 19:12
Смотри также:
установка пароля на обработку
Неверные данные записываются в регистр при проведении документа ТиС 7.7 SQL
Подскажите по последовательности в комплексной

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

angro
1 - 27.07.2009 - 06:51
что пишет про глобальный модуль?

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
2 - 27.07.2009 - 06:53
ОперДок.ВыбратьПроводки();
{Глобальный модуль(16873)}: Операция не выбрана!
 

 
ОперДок = СоздатьОбъект("Операция");
ОперДок.НайтиОперацию(Док);
 
ОперДок.ВыбратьПроводки(); *********************
КоличествоПроводок = ОперДок.КоличествоПроводок();
Для Сч = 1 По КоличествоПроводок Цикл
 
ОперДок.ПолучитьПроводкуПоНомеру(КоличествоПроводок - Сч + 1);
 
// При формировании сводных проводок не удаляем проводки с указанным корр.счетом.
Если (ПустоеЗначение(КоррСчет) = 0) и (Детализация = 2) Тогда
Если (ОперДок.Дебет.Счет = КоррСчет) или
(ОперДок.Кредит.Счет = КоррСчет) Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
 
ОперДок.УдалитьПроводку();
 
КонецЦикла;

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

DaCAT
3 - 27.07.2009 - 07:23
1sentry - это и есть все проводки базы. Если он создан сейчас с нуля, то вручную введённые операции уже не увидеть. Те, что создаются документами при проведении восстановятся, конечно.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

2Green
4 - 27.07.2009 - 07:27
1%, что после перепроведения получишь те проводки, которые были.
ОперДок = СоздатьОбъект("Операция");
Если ОперДок.НайтиОперацию(Док) = 1 Тогда
 
ОперДок.ВыбратьПроводки(); *********************
КоличествоПроводок = ОперДок.КоличествоПроводок();
Для Сч = 1 По КоличествоПроводок Цикл
 
ОперДок.ПолучитьПроводкуПоНомеру(КоличествоПроводок - Сч + 1);
 
// При формировании сводных проводок не удаляем проводки с указанным корр.счетом.
Если (ПустоеЗначение(КоррСчет) = 0) и (Детализация = 2) Тогда
Если (ОперДок.Дебет.Счет = КоррСчет) или
(ОперДок.Кредит.Счет = КоррСчет) Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
 
ОперДок.УдалитьПроводку();
 
КонецЦикла;
КонецЕсли;

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
5 - 27.07.2009 - 07:30
Документы то все остались, многие провелись групповой обработкой. Некоторые не проводятся вылетает ошибка
ОперДок.ВыбратьПроводки();
{Глобальный модуль(16873)}: Операция не выбрана!
Видимо еще каких-то данных не хватает.

Интересные темы

odines.ru
21.10.2020 - 19:12
Смотри также:
Хелп! Перестала работать "Выгрузить данные"
Розничный магазин с собственной продукцией и покупным товаром.
УРИБ нужна помощь

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
6 - 27.07.2009 - 07:53
(4) Так работает только закрытие месяца не проводится ЧО-То еще покопать надо

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
7 - 27.07.2009 - 08:03
(0) Значит так
1) Остатки и оброты помесячно хранятся в файлах базы, слетели только операции ВСЕХ документов
2) Значит, остатки на начало любого месяца сохранились
3) Перепроведение всех документов изменит остатки сделав их неверными (см. посты (3) и (4)). Поэтому документы не перепроводим.
Надеюсь, ты сделал архив до ТИИ? А старых архивов (до сбоя) нет? Предположим, что нет, тогда:
4) Сворачиваем базу на отчетную дату (начало года, квартала, месяца). Из-за 1) свертка сработает.
5) Перепроводим все документы после даты свертки, вручную (по памяти) восстанавливаем операции, введенные вручную. Понятно чем позже дата свертки, тем меньше ручной работы
6) Живем дальше, работая в новой базе
7) Сбойную базу используем как архив, делая станд. бух. отчеты с периодом, кратным месяцу.
 
ЗЫ Если есть архив до сбоя, то все намного проще.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

2Green
8 - 27.07.2009 - 08:07
1sentry - все проводки. 1sbkttl - итоги по всем счетам в разрезе всех субконто. 1saccsel - отборы по счетам

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
9 - 27.07.2009 - 08:13
Не заметил, что 1sbkttl тоже потерян, тогда надежда на архивы.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
10 - 27.07.2009 - 08:14
(7) архивов точно нет :-(((, твой алгоритм понятен. Может что и получится.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
11 - 27.07.2009 - 08:14
У него же ПУБ, тогда проще проводки документов можно воссоздать из регистров. Без перепроведения, обработкой.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

2Green
12 - 27.07.2009 - 08:20
victuan, за ВМФ вчера пил?

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
13 - 27.07.2009 - 08:26
(12) Нет, я трезв и ум ясен.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

USSR
14 - 27.07.2009 - 08:27
в ПУБ проводки реализованы сумбурно, они не все нанизаны на регистры как в ТИС.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

USSR
15 - 27.07.2009 - 08:27
точнее как в комплексной, но не суть

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
16 - 27.07.2009 - 08:30
(11)+ Конечно, полностью без перепроведения не получится, тут я себя поправлю. Однако, можно сделать через "умное проведение": запретить изменение движений по регистрам (значит сохраним партионный учет, себест-ть, взаиморасчеты контрагентов). Учитывая, что последовательность обеспечивается движениями по регистрам, то можно рискнуть и перепровести документы только для воссоздания проводок. Возможно, результат получится не сильно отличичающийся от первоначального. (но ручные операции, конечно, придется восстанавливать по памяти)

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
17 - 27.07.2009 - 08:31
(22) Те, которые могут измениться из-за проведения, по-моему, почти все нанизаны как в Комплексной.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

2Green
18 - 27.07.2009 - 08:50
(16) victuan, и что будешь делать после того как движения по регистрам не будут совпадать с проводками?

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
19 - 27.07.2009 - 09:42
(18) Почему "движения по регистрам не будут совпадать с проводками"?

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

VZ
20 - 27.07.2009 - 10:22
(19) Потомушто это заданное условие восстановления движений. Не ожидание "все будет хорошо", а условие. Т.е., любой алгоритм восстановления проводок считается некорректным до применения, пока в нем не будет проверки и обработки этого условия.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

victuan
21 - 27.07.2009 - 10:27
(20) Главное, было бы с чем проверять(хотя бы с бумажными носителями).
Разве ПУБ не обеспечивает равенство регистров и проводок, которые имеют отражение в проводках?
Именно поэтому в этой части проводок не должно быть отклонений.
Остается подумать какие проводки могут изменить результат после проведения, а это зависит от наполнения конкретной базы.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

USSR
22 - 27.07.2009 - 10:52
я думаю, что раз не проводятся доки целиком, то не проведутся и при сохранении движений по регистрам.У него непорядок именно с проводками. Тем более повторяю, что ряд проводок пишется не в глобальнике по регистрам, а в модулях документов. При таком отношении к базам данная организация и автор заслуживают своего итога.
Не удивлюсь, если у них нет ни обороток, ни балансов.
Уж если проводить, то мне кажется надо целиком. Исправить ошибки при проведении, и все провести. И затем уже смотреть что получится. Так хоть что-то можно будет понять, а иначе накладывать проводки на возможно (т наверняка) неактуальные уже движения мне кажется тупиковый путь. Просто потом не разобраться. И при первом проведении задним числом вся эта хлипкая конструкция "на сохраненных движениях" хрустнет и крякнет известным,  мелодичным звуком.
 

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

VZ
23 - 27.07.2009 - 11:12
Бэкапов и архивов нет
Хотя бэкапы надо делать хотя бы при реорганизации МД-ника. А поводов для этого предостаточно хотя бы из-за регламеньных отчетов...
 
Где такую картинку можно отыскать? Где курицы-бушки, студент на подхвате, и куроводство, мечтающее о персонале "за суп"...
Потому сабж просто неинтересен: нудная, кропотливая, квалифицированная работа оплачена по достоинству не будет...

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

drums2004
24 - 27.07.2009 - 12:12
да-с ....караментельня фраза  бакапов нет

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

ubah
25 - 27.07.2009 - 17:17
VSE PREKRASNO понимают, что первая заповедь любого пользователя персонального компьютера SDELAY бекап и еще одну |{ 0 |~| i |-@ на внешний носитель. Здесь вовсе необязательно быть одинесником или кудесником. И у нас на двухвинтовом серваке они делались ежесуточно. Кто мог предположить, что когда один винт начнет разрушаться, при синхронизацизации в рейде кривые данные начнут накатывать на хороший винт. А так оно и случилось. Получилось, что двух винтовая система не спасла, а ZAGУбила. Так, что копируйте на флешку или дискету)))

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

angro
26 - 27.07.2009 - 17:42
хранить бекапы на том же винте не камильфо

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

reanimator
27 - 27.07.2009 - 18:51
(25) Вообще, давно известно, что "рэйд" полезен почти исключительно для спасения информации при пулевом попадании в один винт, да и то если пуля второй винт не заденет... ;) Во всех остальных случаях он бесполезен.

Re: Можно ли восстановить базу (хотя бы протелепатируйте)

drums2004
28 - 27.07.2009 - 19:39
раид...раид.. у меня бакап ночью н дву машинкм итет по сети ...несмотря на раид на сервере ... у шефа гикнулсся винт на 500 гиг ...глаза вытаращил  - как так ??? вчера еще работал и ??? я ему - а ты что хотел  - чтобы он тебе заявление написал за две недели ?  
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Бюджетка. Прислали файлы из казначейства. Через что их загружать? Обновления через ИТС »
© 2009 Форум 1С: Одинэс.Ру