Интервал просмотра для журнала документов

Форум 1С: Одинэс.Ру

Найти!

Интервал просмотра для журнала документов

Неташка
02.03.2009 - 12:47
для стандартных журналов устанавливается интервал просмотра:
Сервис->Параметры->Журналы
как программно подхватить тот интервал, который пользователь для себя определил.
К списку тем К списку форумов

Интересные темы

odines.ru
22.10.2020 - 13:07
Смотри также:
v7. Во все печатные формы конфигурации нужно добавить колонтитулы. Как оптимальнее?
установка флага на форме без атрибута программно
Помогите побороть табличную часть документа

Re: Интервал просмотра для журнала документов

VZ
1 - 02.03.2009 - 12:56
НачалоИнтервала(), КонецИнтервала()
Стесняюсь спросить: а зачем?

Re: Интервал просмотра для журнала документов

Неташка
2 - 02.03.2009 - 13:05
:)
есть обработка, которой пользуются пользователи вместо стандартного журнала документов.

Re: Интервал просмотра для журнала документов

Неташка
3 - 02.03.2009 - 13:07
(1)
НачалоИнтервала()
Синтаксис:
НачалоИнтервала()
Назначение:
Возвращает дату начала интервала журнала операций.
Замечание:
Метод доступен только в контексте Модуля формы журнала операций.

Re: Интервал просмотра для журнала документов

VZ
4 - 02.03.2009 - 13:10
(2) Тогда придется открыть форму журнала документов. Не смущает?

Re: Интервал просмотра для журнала документов

Ctrl P
5 - 02.03.2009 - 14:19
вот нашел
В обработке код:
 
Перем Статус, СписокПараметров;
 
//*******************************************
Функция Интервал()
Если (ПустоеЗначение(НачалоИнтервала)=1) или (ПустоеЗначение(КонецИнтервала) = 1) Тогда
Статус = 0;
Форма.Закрыть();
КонецЕсли;
КонецФункции
 
//======================================================================
Процедура ПриОткрытии()
Статус = 1;
СписокПараметров = СоздатьОбъект("СписокЗначений");
СписокПараметров.ДобавитьЗначение("ИнтервалЖурнала","Команда");
Путь = "";
Файл = "";
РасположениеФайла(Путь,Файл);
НазваниеВызываемойФормы = Путь+Файл;
СписокПараметров.ДобавитьЗначение(НазваниеВызываемойФормы,"Форма");
СписокПараметров.ДобавитьЗначение("Отчет","ВидФормы");
КонецПроцедуры // ПриОткрытии
 
//======================================================================
Процедура ПриЗакрытии()
Если Статус = 0 Тогда
ОткрытьФорму("Журнал.Общий#", СписокПараметров);
СтатусВозврата(Статус);
КонецЕсли;
Статус = 1;
КонецПроцедуры // ПриЗакрытии
//======================================================================
Процедура ПриПовторномОткрытии()
Если Пустоезначение(Форма.Параметр) = 0 тогда
Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" тогда
Если Форма.Параметр.Получить("Команда") = "ИнтервалЖурнала" тогда
НачалоИнтервала = Форма.Параметр.Получить("НачалоИнтервала");
КОнецИнтервала = Форма.Параметр.Получить("КонецИнтервала");
Возврат;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры // ПриПовторномОткрытии
 
на форме три объекта два реквизита диалога типа "дата" "НачалоИнтервала" и "КонецИнтервала" и текст с вызовом функции Интервал();
А в модуле формы общего журнала в процедуре приоткрытии() вот такой вот код:
Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
Если Форма.Параметр.Получить("Команда") = "ИнтервалЖурнала" Тогда
СтатусВозврата(0);
Форма.Параметр.ДобавитьЗначение(НачалоИнтервала(),"НачалоИнтервала");
Форма.Параметр.ДобавитьЗначение(КонецИнтервала(),"КонецИнтервала");
Если Форма.Параметр.Получить("ВидФормы") = "Отчет" Тогда
ОткрытьФорму(Форма.Параметр.Получить("ВидФормы"),Форма.Параметр,Форма.Параметр.Получить("Форма"));
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
 
ЗЫ. можно было бы и через ОткрытьФормуМодально, но почему то не хотелось "Модально"...

Интересные темы

odines.ru
22.10.2020 - 13:07
Смотри также:
реквизит типа "Документ"
Помогите. Тормозит поиск по справочнику при работе 2х компьютеров.
Авансовый отчет в валюте

Re: Интервал просмотра для журнала документов

Ctrl P
6 - 02.03.2009 - 14:22
просто с некоторых пор для меня оказалось открытием, что можно передавать пареметры между формами открытыми и не модально, хотя не раз мне твердили что передавать параметры можно только через ОткрытьФормуМодально(), а оказывается что не только!!!

Re: Интервал просмотра для журнала документов

VZ
7 - 02.03.2009 - 14:44
(5, 6) Зачем все это? Обработка автора умеет самостоятельно сохранять значения своих реквизитов без обращения к другим объектам. В контексте сабжа вообще не вижу причин лазать куда-то или принимать параметры.
Разве что брать общие параметры из профиля юзера....

Re: Интервал просмотра для журнала документов

Uho
8 - 02.03.2009 - 14:51
(7) "Разве что брать общие параметры из профиля юзера...."
а если они изменены в текущем сеансе?

Re: Интервал просмотра для журнала документов

Ctrl P
9 - 02.03.2009 - 16:04
...Разве что брать общие параметры из профиля юзера
ну я так и понял из 0: "Сервис->Параметры->Журналы
как программно подхватить тот интервал, который пользователь для себя определил."

Re: Интервал просмотра для журнала документов

pit
10 - 02.03.2009 - 16:41
пример процедуры, открывающей форму основного журнала документа, проверяющей, будет ли виден док в журнале (и корректирующей начало-конец интервала журнала по дате дока)
 
//===============================================================================  
// открытие журнала и позиционирование документа в нем. Желательно поместить в ГМ.
// Моисеенко
//===============================================================================
procedure  глОткрытьЖурналИвстатьНаДокумент(Док) Export
if Док.Selected() =0 then return;  endIf;
Журнал = Metadata.Document(Док.Kind()).Journal.FullIdentifier();
КФ="";
if OpenForm(Журнал, КФ) = 1 then
try          
_ДатаНач_=КФ.BegOfRange();
_ДатаКон_= КФ.EndOfRange();
УстИнтервал=0;
if Док.ДатаДок < _ДатаНач_  then _ДатаНач_ = Док.ДатаДок; УстИнтервал=1; endIf;
if Док.ДатаДок > _ДатаКон_  then  _ДатаКон_= Док.ДатаДок;  УстИнтервал=1; endIf;
if УстИнтервал=1  then КФ.УстановитьИнтервал(_ДатаНач_,_ДатаКон_); endIf;
КФ.ActivateObj(Док);
except
endTry;
endIf;
EndProcedure  
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« УРБД + The Bat! 3.80 УСН (релиз 160), посмотрите, есть ли в типовой такая константа ??? »
© 2009 Форум 1С: Одинэс.Ру