Подскажите пожалуйста где ошибка?

Форум 1С: Одинэс.Ру

Найти!

Подскажите пожалуйста где ошибка?

impulse
16.03.2009 - 09:04
Создает позицию в спр.номенклатура, а "шт." ей не назначает,
 
Процедура ВыборФайла()
Перем имяфайла,имяпути , ст;
 
док = СоздатьОбъект("Документ.РеализацияРозница");
Спр=СоздатьОбъект("Справочник.Номенклатура");
Тст=СоздатьОбъект("Текст");
ЕН=СоздатьОбъект("СписокЗначений");
Имяфайла="";
ИмяПути="";    
ФС.ВыбратьФайл(0,ИмяФайла,ИмяПути,"Выберите файл","Файлы текста|*.txt",,);
ИмяФайла=ИмяПути+ИмяФайла;
 
стр ="";
Если ПустоеЗначение(ИмяФайла)=0 Тогда
 
Тст.Открыть(ИмяФайла);
КоличествоСтрок = тст.КоличествоСтрок();
Для ккк=1 По тст.КоличествоСтрок() Цикл
ЕН.УдалитьВсе();
стр = Тст.ПолучитьСтроку(ккк);
ЕН.ИзСтрокиСРазделителями(стр);
Сообщить(стр);
 
Если ЕН.ПолучитьЗначение(5)<>"РеализацияРозница" Тогда
Сообщить("Выбранный файл поврежден или не содержит необходимую для загрузки информацию !");
Возврат;
КонецЕсли;            
 

Если ЕН.ПолучитьЗначение(1)<>"Н" Тогда
Сообщить("Загружена позиция...");
КонецЕсли;            
 
Если ЕН.ПолучитьЗначение(1)<>"Д" Тогда
Сообщить("Загружена позиция...");
УдалитьСтроки();
сообщить("Загрузка накладной  "+строка(ЕН.ПолучитьЗначение(6))+"...");    
НомерДок = ЕН.ПолучитьЗначение(6);
ДатаДок = ЕН.ПолучитьЗначение(7);
НоваяСтрока();
Номенклатура = Спр.НайтиПоКоду(ЕН.ПолучитьЗначение(1),0);
ВидТМЦ=Перечисление.ВидыТмц.ЗначениеПоНомеру(1);
Номенклатура=Спр.ТекущийЭлемент();
ПриИзмененииНоменклатуры();
Количество = число(ЕН.ПолучитьЗначение(3));
Единица = Спр.ТекущийЭлемент().БазоваяЕдиница;
Коэффициент = 1;
Цена = число(ЕН.ПолучитьЗначение(2));
РозничнаяЦена = Цена;
РозничнаяНаценка = 0;
СуммаНаценки = 0;
Сумма = число(Цена*Количество);
Доставка = "";
 
сообщить("Всего номенклатуры"+" "+Итог("Количество"));
сообщить("Сумма накладной "+"   "+глФРМ(Итог("Сумма")+?(СуммаВклНП=1,0,Итог("СуммаНП"))+?(СуммаВклНДС=1,0,Итог("СуммаНДС")))+"   "+" руб.");
сообщить(строка(ЕН.ПолучитьЗначение(3))+"  успешно загружена !");
сообщить("---------------------------------------------------------");
 
Записать();
Провести();
КонецЕсли;            
КонецЦикла;
 
Иначе
Сообщить("Не был выбран файл загрузки !","!!!");
Сообщить("---------------------------------------------------------");
Возврат;
КонецЕсли;
 
КонецПроцедуры //загрузка
К списку тем К списку форумов

Интересные темы

odines.ru
28.10.2021 - 00:09
Смотри также:
Объясните про "ИтогиАктуальны()"
1C Тис 7.7 Как изменить код номеклатуры?
Свертка базы

Re: Подскажите пожалуйста где ошибка?

iogri
1 - 16.03.2009 - 09:24
Единица = Спр.ТекущийЭлемент().БазоваяЕдиница;
Как я понял, происходит присвоение значения реквизиту табличной части документа. А какого типа этот реквизит? Если неопределенного, то сначала надо назначить тип, а потом присваивать.

Re: Подскажите пожалуйста где ошибка?

impulse
2 - 30.04.2009 - 05:58
Хм, а можно уточнить как это сделать?
так?
Единица =СоздатьОбъект("Справочник.ОКЕИ");

Re: Подскажите пожалуйста где ошибка?

roma n
3 - 30.04.2009 - 06:03
"Создает позицию в спр.номенклатура" - приведенный кусок кода никаких позиций в справочнике не создает.

Re: Подскажите пожалуйста где ошибка?

SMOKE
4 - 30.04.2009 - 06:10
Может так:
СпрЕд =СоздатьОбъект("Справочник.Единицы");
ТекЕдиница = СпрЕд.НайтиЭлемен(Номенклатура.БазоваяЕдиница);
Единица = ТекЕдиница;

Re: Подскажите пожалуйста где ошибка?

Sasha
5 - 30.04.2009 - 06:30
Я думаю всё гораздо банальнее, реквизит "Базовая единица" у данной номенклатуры - пустое значение.

Интересные темы

odines.ru
28.10.2021 - 00:09
Смотри также:
Штрих-код
Возврат товара - помогите разобраться с себестоимостью
УРБД по элементам справочника.

Re: Подскажите пожалуйста где ошибка?

Гуня
6 - 30.04.2009 - 07:14
(3) Это наверное с документом он попутал.
Возможно поиск в справочнике номенклатура не состоялся. Надо условие поставить типа
Если Спр.НайтиПоКоду(ЕН.ПолучитьЗначение(1),0)=1 Тогда
......
КонецЕсли;
К списку тем К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Свертка базы - вопрос про ввод остатков Как сделать, чтоб спрашивал время документа при записи Чека ККМ? »
© 2009 Форум 1С: Одинэс.Ру