Отбор документов по дате, что-то не получается...

Форум 1С: Одинэс.Ру

Найти!

Отбор документов по дате, что-то не получается...

deefm
22.04.2009 - 05:03
Здравствуйте, есть самописный документ "Договор". В нем есть реквизит ДатаРег. Пишу внешний отчет, у которой на форме вводится пользователем диапазон дат: НачДата и КонДата. Надо, чтобы отбирал только те документы, у которых реквизит ДатаРег попадает в этот диапазон.  Сейчас он вообще этот реквизит не видит, т.к. я что-то не пойму, как поставить это условие... Вот мой код:
 

Док = СоздатьОбъект("Документ.Договор");
Док.ВыбратьДокументы(НачДата, КонДата);
Пока Док.ПолучитьДокумент() = 1 Цикл
        ...
        КонецЦикла;
К списку тем К списку форумов

Интересные темы

odines.ru
25.10.2020 - 22:36
Смотри также:
Не ищет "НайтиЗначение" в ТЗ.
ошибка при работе с sql-ной базой
установка флага на форме без атрибута программно

Re: Отбор документов по дате, что-то не получается...

Sasha
1 - 22.04.2009 - 05:07
(0)Одно из решений - запрос. Можно через конструктор

Re: Отбор документов по дате, что-то не получается...

banzay
2 - 22.04.2009 - 05:09
"НачДата" и "КонДата" сравниваются с реквизитом "ДатаДок", а не с "ДатаРег".
Можно так:
Док = СоздатьОбъект("Документ.Договор");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
  Если (Док.ДатаРег>=НачДата) И (Док.ДатаРег<=КонДата) Тогда
    //трам трам
  КонецЕсли;
КонецЦикла;

Re: Отбор документов по дате, что-то не получается...

deefm
3 - 22.04.2009 - 05:16
(2) точно! большое СПАСИБО!!!

Re: Отбор документов по дате, что-то не получается...

Sasha
4 - 22.04.2009 - 05:20
(3)Это хорошо, если документов немного :-)
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Addin.V7Sysinfo КЛАДР »
© 2009 Форум 1С: Одинэс.Ру