Проблемка с поиском в списке значений

Форум 1С: Одинэс.Ру

Найти!

Проблемка с поиском в списке значений

SmileS
24.02.2009 - 19:20
Есть список значений уже ранее заполненный.
Пытаюсь используя команду НайтиЗначение найти нужную мне строку, но поиск почему-то не проходит, выдаёт значение 0, хотя точно в списке значения есть строка с таким параметром.
 
СписокЗначений.НайтиЗначение(Строка);
 
Строка - это значение, по которому ищу аналогичное значение в спискезначений.
 
Методом методичного выбора строк и сравнения результатов строка находится, а через НайтиЗначение никак.
Где я туплю?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
01.12.2020 - 20:29
Смотри также:
Почему поле недоступно сразу
Запуск 1С
Как вывести остатки?

Re: Проблемка с поиском в списке значений

VZ
1 - 24.02.2009 - 19:26
В коде.

Re: Проблемка с поиском в списке значений

SmileS
2 - 24.02.2009 - 19:28
ясно что в коде, где именно?

Re: Проблемка с поиском в списке значений

Reaper
3 - 24.02.2009 - 19:30
В типах данных накосячил, 100%.

Re: Проблемка с поиском в списке значений

SmileS
4 - 24.02.2009 - 19:32
неа, типы данных впорядке на 100%
я специально проверил при выборке списка значений и сравнения
Там совпадают данные
 
стр = "";
Для Номер = 1 По СписокЗначений.РазмерСписка() Цикл
значение = СписокЗначений.ПолучитьЗначение(Номер, стр);
Если стр = СтрокаЗн Тогда
// в итоге здесь находятся соответствия
КонецЕсли;
КонецЦикла;

Re: Проблемка с поиском в списке значений

VZ
5 - 24.02.2009 - 19:36
+3
(4) Да мы тебя не уговариваем :) Значит, у тебя персональный экземпляр движка... А у нас - серийный. Который с этим делом издавна штатно работал.

Интересные темы

odines.ru
01.12.2020 - 20:29
Смотри также:
установка пароля на обработку
Простой Запрос
Падает 1С при открытии обработки загрузки/выгрузки проводок

Re: Проблемка с поиском в списке значений

Ctrl P
6 - 24.02.2009 - 19:38
4 ты че издеваешься, в стр у тебя не значение а представление находится

Re: Проблемка с поиском в списке значений

Ctrl P
7 - 24.02.2009 - 19:39
такое исчетца через ПустоеЗначение(СписокЗначений.Получить(стр));
в 1с чудес не бывает (с)

Re: Проблемка с поиском в списке значений

SmileS
8 - 24.02.2009 - 19:51
Проверил и тип данных (строка) и значения совпадают.
Но поиск всё равно не работает:(

Re: Проблемка с поиском в списке значений

Ctrl P
9 - 24.02.2009 - 19:55
чё ты проверил?
вместо:
// в итоге здесь находятся соответствия
Напиши
Сообщить(Значение);
Сообщить(СтрокаЗн);
Сообщить(Стр);
и результат сюда показывай...

Re: Проблемка с поиском в списке значений

VZ
10 - 24.02.2009 - 19:59
Не. Не так:
Сообщить("Значение = """+Значение+""" ("+ТипЗначенияСтр+")");
Сообщить("СтрокаЗн = """+СтрокаЗн+""" ("+ТипЗначенияСтр+")");

Re: Проблемка с поиском в списке значений

VZ
11 - 24.02.2009 - 20:00
+10 Тьху. Забыл аргумент :)
Сообщить("Значение = """+Значение+""" ("+ТипЗначенияСтр(Значение)+")");
Сообщить("СтрокаЗн = """+СтрокаЗн+""" ("+ТипЗначенияСтр(СтрокаЗн)+")");
Ну ты понял :)

Re: Проблемка с поиском в списке значений

SmileS
12 - 24.02.2009 - 20:13
что я проверить не в состоянии чтоли
вот пожалуйста
 
Значение = "5%" (Строка) - это при выборке из списка значений
а это
Значение = "5%" (Строка) - параметр по которому я пытаюсь искать в списке значений.

Re: Проблемка с поиском в списке значений

VZ
13 - 24.02.2009 - 20:17
Не верю. Код целиком давай.

Re: Проблемка с поиском в списке значений

Ctrl P
14 - 24.02.2009 - 20:18
А СтрокаЗН чему равна?

Re: Проблемка с поиском в списке значений

SmileS
15 - 24.02.2009 - 20:22
целиком большой будет
счас скомпаную важные моменты
 
СтрокаЗН в данный момент равна 5%

Re: Проблемка с поиском в списке значений

Ctrl P
16 - 24.02.2009 - 20:26
15 так вот и напиши это копи-пастом сюда, а не отсебятину как в 12...
скопируй в код 12, а потом из ОкнаСообщений сюда результат...

Re: Проблемка с поиском в списке значений

SmileS
17 - 24.02.2009 - 20:29
результат изокна сообщений я вообщето ранее показал
код сейчас напишу
 
стр = "";
Для Номер = 1 По СписокТипыЦен.РазмерСписка() Цикл
значение = СписокТипыЦен.ПолучитьЗначение(Номер, стр);
Сообщить("Значение = """+стр+""" ("+ТипЗначенияСтр(стр)+")");
КонецЦикла;
 
СписокЦен.ВыбратьСтроки(); // СписокЦен это ТаблицаЗначений
Пока СписокЦен.ПолучитьСтроку()=1 Цикл
 
СтрокаЗН = СписокЦен.ТипЦены;
Сообщить("Значение = """+СтрокаЗН+""" ("+ТипЗначенияСтр(СтрокаЗН)+")");
        СписокТипыЦен.НайтиЗначение(СтрокаЗН); //вот здесь пытаюсь найти данные соответствия
КонецЦикла;

Re: Проблемка с поиском в списке значений

Ctrl P
18 - 24.02.2009 - 20:33
друк... тежсказали копи-пастом...
а ты опять отсебятину поришь...
Сообщить("Значение = """+стр+""" ("+ТипЗначенияСтр(стр)+")");
не надо
а надо
Сообщить("Значение = """+Значение+""" ("+ТипЗначенияСтр(Значение)+")");
...
а переменная "стр" нафиг тут не нужна

Re: Проблемка с поиском в списке значений

SmileS
19 - 24.02.2009 - 20:40
переменная "Значение" это вообще-то номер строки СпискаЗначений

Re: Проблемка с поиском в списке значений

Ctrl P
20 - 24.02.2009 - 20:46
19 да ладно?
переменная "Номер" это вообще-то номер строки СпискаЗначений (из 17)

Re: Проблемка с поиском в списке значений

SmileS
21 - 24.02.2009 - 20:50
"номер" тоже указывает номер строки
А переменная "Стр" как раз соответсвует данным строки СпискаЗначений

Re: Проблемка с поиском в списке значений

Ctrl P
22 - 24.02.2009 - 20:54
21 не бреши (с)
СписокЗначений.ДобавитьЗначение("Шайба","Гномик");
Стр = "";
Для Номер = 1 по СписокЗначений.РазмерСписка() цикл
Значение = СписокЗначений.ПолучитьЗначение(Номер,Стр);
Прервать;
КонецЦикла;
в этом примере
Значение = "Шайба";
Стр = "Гномик";
Номер = 1;
вообще СП хорошо почитай, метод ПолучитьЗначение() в частности...

Re: Проблемка с поиском в списке значений

SmileS
23 - 24.02.2009 - 20:56
ок, счас погляжу
привык пользоваться таблицей значений:)

Re: Проблемка с поиском в списке значений

user1C
24 - 24.02.2009 - 21:13
(0)
как заполняется СписокТипыЦен и СписокЦен.ТипЦены?

Re: Проблемка с поиском в списке значений

SmileS
25 - 24.02.2009 - 21:18
сам дурак, каюсь, неправильно список значений заполнял

Re: Проблемка с поиском в списке значений

VZ
26 - 24.02.2009 - 23:01
ЧТД

Re: Проблемка с поиском в списке значений

tsd
27 - 25.02.2009 - 04:33
прикольно, для того чтобы понять, что сам дурак понадобились всего какие-то сутки :)
 
ЗЫ: глаз нет, зато руки как у пианиста

Re: Проблемка с поиском в списке значений

Reaper
28 - 25.02.2009 - 06:59
[офф]Я ж говорил![/офф]
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Работа с 002 счетом в Комплексной Объединение печатных форм »
© 2009 Форум 1С: Одинэс.Ру