V7 With Excell: Как организовать гиперссылку?

Форум 1С: Одинэс.Ру

Найти!

V7 With Excell: Как организовать гиперссылку?

ANik
02.02.2009 - 16:28
Вроде гиперссылка получается, но никуда не ссылается.
Вот что говорит СП по Excell:
Синтаксис:
Add(Anchor, Address, SubAddress, ScreenTip, TextToDisplay)
Параметры:
<Anchor> - VT_DISPATCH
<Address> - Строка (VT_BSTR)
<SubAddress> - VT_VARIANT
<ScreenTip> - VT_VARIANT
<TextToDisplay> - VT_VARIANT
И как это перевести на 1С?
К списку тем К списку форумов

Интересные темы

odines.ru
19.09.2021 - 20:21
Смотри также:
ПУБ: сколько сырья и материалов в себестоимости продаж
УРБД - если накроется база, то как быть ?
Кассовая книга

Re: V7 With Excell: Как организовать гиперссылку?

ANik
1 - 02.02.2009 - 16:29
Текст тестовой программы:
Процедура Сформировать()
ОкноExcel=СоздатьОбъект("Excel.Application");
    ОкноExcel.Caption="Прайс";  
ОкноExcel.Visible=1;
    
    НовыеРабочиеКниги=ОкноExcel.Workbooks;
    РабочаяКнига=НовыеРабочиеКниги.Add(1);
Страница=РабочаяКнига.Worksheets(1);
Страница.Name="Оглавление";
Страница2=РабочаяКнига.Worksheets().add();
Страница2.Name="Группа № 1";
Страница.Move(РабочаяКнига.Worksheets(1));
Страница3=РабочаяКнига.Worksheets().add();
Страница3.Name="Группа № 2";
Страница.Move(РабочаяКнига.Worksheets(1));
Страница2.Move(РабочаяКнига.Worksheets(2));
Страница.Select();
ГиперСсылка=Страница.HyperLinks;
ГиперСсылка.Add(РабочаяКнига.Worksheets(1).Cells(1,1),РабочаяКнига.Worksheets(2).Cells(1,1),"Гипер");
КонецПроцедуры

Re: V7 With Excell: Как организовать гиперссылку?

ANik
2 - 03.02.2009 - 05:42
Разобрался
Перем ОкноExcel, РабочаяКнига, Страница;
Процедура СоздатьГиперСсылки(Список)
Страница=РабочаяКнига.WorkSheets.Add();
Страница.Name="Оглавление";
НомерСсылки=0;
СчетчикЦикла = 0;
Для СчетчикЦикла = 1 По Список.РазмерСписка() Цикл
// Вставляем гиперссылку из оглавления на страницу
НомерСсылки=НомерСсылки+1;
ГиперСсылка=Страница.HyperLinks;
ТекстГиперссылки=РабочаяКнига.WorkSheets(СчетчикЦикла+1).Name;
ГиперСсылка.Add(РабочаяКнига.Worksheets(1).Cells(СчетчикЦикла,2),РабочаяКнига.Worksheets(2).Cells(1,1),ТекстГиперссылки);
Страница.HyperLinks(НомерСсылки).SubAddress="'"+ТекстГиперссылки+"'!R1C1";
ГиперСсылка=РабочаяКнига.Worksheets(СчетчикЦикла+1).HyperLinks;
ГиперСсылка.Add(РабочаяКнига.Worksheets(СчетчикЦикла+1).Cells(2,2),РабочаяКнига.Worksheets(1).Cells(1,1),"Оглавление");
РабочаяКнига.WorkSheets(СчетчикЦикла+1).HyperLinks(1).SubAddress="'Оглавление'!R1C1";
КонецЦикла;
КонецПроцедуры // СоздатьГиперСсылки(Список);()
ОкноExcel=СоздатьОбъект("Excel.Application");
    ОкноExcel.Caption="Счет";  
    
    НовыеРабочиеКниги=ОкноExcel.Workbooks;
    РабочаяКнига=НовыеРабочиеКниги.Add(1);
Инд = 0;
Для Инд = 1 По Список.РазмерСписка() Цикл
ТекущаяГруппа=Список.ПолучитьЗначение(Список.РазмерСписка()+1-Инд);
ВывестиСтраницу(ТекущаяГруппа,?(Инд=1,1,0));
КонецЦикла;
 
СоздатьГиперСсылки(Список);
 
ОкноExcel.Visible=1;
К списку тем К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« ЗиК Расчет б/л при ЕНВД Видимость элементов списка справочника »
© 2009 Форум 1С: Одинэс.Ру