КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

Форум 1С: Одинэс.Ру

Найти!

КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
11.03.2009 - 09:23
Здравствуйте, подскажите пож-та, как можно отредактировать типовой отчет КарточкаСчета, чтобы если у выбранного счета субконто - ВидыНоменклатуры, это субконто не выводилось бы... Много места занимает, а информация эта в отчете для нас - абсолютно лишняя...
Посмотрела в конфигураторе - там в самой печ.форме стоит  Опер.ПредставлениеПроводки(1). Пробовала по-всякому, все равно выходит... Может быть кто-нибудь сталкивался с подобной проблемой???
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
27.10.2021 - 22:04
Смотри также:
-ОФФ- Подскажите, ошибка в номере ИНН может привести к незачислению денег на р/с клиента?
Перепроведение документов DBF
Кто как ведет в типовой бухгалтерии учет по обособленным подразделениям

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
1 - 11.03.2009 - 10:41
+(0) нашла решение похожей проблемы на http://www.sinor.ru/%7Emy1c/knowhow/shortpr.html
Там советуют:
// В отчетах колонка "Операции" заполняется информацией о субконто проводки,
// которые подчас дублируются, что ведет к неоправданному росту длины отчета.
// Сделал свою и вставил в отчеты:
// вызов МоеПредставлениеПроводки(Опер.ПредставлениеПроводки(1))
Функция МоеПредставлениеПроводки(стр) Экспорт
     рез="";
     Для нс=1 по СтрКоличествоСтрок(стр) Цикл
          с=СтрПолучитьСтроку(стр,нс);
          Если (с<>"<...>") тогда
               Если (Найти(рез,с)=0) тогда
                    рез=рез+СОКРЛП(с)+РазделительСтрок;
               КонецЕсли;
          КонецЕсли;
     КонецЦикла;
     Возврат рез;
КонецФункции
 

 
Подскажите пожалуйста, более опытные коллеги, куда в отчете вставлять вызов этой функции МоеПредставлениеПроводки???

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
2 - 11.03.2009 - 12:00
+(0) В печ.форме таблицы, в колонке"Операции" стоит <Опер.ПредставлениеПроводки(1)>.
В итоге в этой ячейке слишком много информации. Как сделать, чтобы в этом поле не выводилось субконто ВидыНоменклатуры?

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

Хряк
3 - 11.03.2009 - 12:09
Ну вот туда и вставь вместо Опер.ПредставлениеПроводки(1)
МоеПредставлениеПроводки(Опер.ПредставлениеПроводки(1))

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

user1C
4 - 11.03.2009 - 12:12
(0)
ПредставлениеПроводки
Получить представление для текущей проводки.
 
Синтаксис:
 
ПредставлениеПроводки(<ПоСубконто>)
 
Англоязычный синоним:
 
Entry Presentation
 
Параметры:
 
<ПоСубконто> Необязательный параметр. Флаг включения в пред­ставление проводки представления субконто провод­ки. Число:
 
0 — не включать представление субконто;
 
1 — включать представление субконто;
 
2 — включать развернутое представление субконто. Значение по умолчанию: 0.
 
Возвращаемое значение:
 
Строка — представление для текущей проводки.
 
Описание:
 
Представлением называется символьная строка, содержащая информацию из реквизитов проводки и операции. Эта строка может быть использована для отображения проводки в различных отчетах, диалогах и других визуальных элементах конфигурации. Формат представления определяется в конфигурато­ре при редактировании свойств проводки.
 
Метод ПредставлениеПроводки позволяет получить представление для текущей проводки.
 
Параметр метода позволяет указать, включать ли в представление проводки и представление субконто проводки. Представление субконо содержит инфор­мацию из реквизитов значения субконто. Представление может быть задано в конфигураторе при редактировании свойств вида субконто.

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
5 - 11.03.2009 - 12:13
(3) В печ.форме вместо Опер.ПредставлениеПроводки(1)
поставила МоеПредставлениеПроводки(Опер.ПредставлениеПроводки(1)). В начале модуля написала код из (1), и все равно вываливает все подряд.
P.S. Код из (1) для дублирующихся субконто, а у меня таких нет, мне надо именно убрать субконто ВидыНоменклатуры, если, например формирую КарточкуСчета по 40 или 43 счету.

Интересные темы

odines.ru
27.10.2021 - 22:04
Смотри также:
Какие должны быть проводки?
Нумерация 2НДФЛ в 1С:Налогоплатещик 7.7
Возврат поставщику?

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
6 - 11.03.2009 - 12:16
(4) Пробовала я ставить и Опер.ПредставлениеПроводки(0) и Опер.ПредставлениеПроводки(1). Бесполезно...
 

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

user1C
7 - 11.03.2009 - 12:30
(6)
ничего не меняется?

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
8 - 11.03.2009 - 12:42
(7) Нет, выводится одинаково, все в куче :(

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

user1C
9 - 11.03.2009 - 12:45
(8)
следовательно, не там меняешь...

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
10 - 11.03.2009 - 12:47
(9) я цветом выделила секцию, так что промахнуться вроде не могла...

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

user1C
11 - 11.03.2009 - 15:12
(10)
чудес не бывает...

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
12 - 12.03.2009 - 12:20
В печ.форме вместо <Опер.ПредставлениеПроводки(1)>, написала <вывод>, а в модуле отчета Карточка Счета, в процедуре Процедура ВывестиПроводку(Ит, Т, Опер, Дт, Кт) добавила:
//ниже код из типового отчета
...
Процедура ВывестиПроводку(Ит, Т, Опер, Дт, Кт)
Расшифровка.Установить("НомерКорреспонденции", Опер.НомерКорреспонденции());
 
СД = Ит.СКД()-Ит.СКК();
Если Количественный = 1 Тогда
Если (ОтборСубк1 <> 2) И (ОтборСубк2 <> 2) И (ОтборСубк3 <> 2) Тогда
Если (Опер.ВалСумма <> 0) Или (ПоВалюте = 1) Тогда
Если ПоВалюте = 1 Тогда
СДВал = Ит.СКД(2)-Ит.СКК(2);
Т.ВывестиСекцию("Секция_6_7_1");
Иначе
Т.ВывестиСекцию("Секция_6_1_7_1");
КонецЕсли;
Иначе  
// здесь ниже мои вставленные строчки
/////////////////////////////////////
Рез = "";
Если Опер.Дебет.Счет = "43" Тогда
Рез = опер.дебет.субконто(1);
Иначе
Рез = Опер.ПредставлениеПроводки(1);
КонецЕсли;
// конец моей вставки
 
Т.ВывестиСекцию("Секция_7_1");
КонецЕсли;
...
 

Все равно вываливает всю информацию по проводке... Смотрю через отладчик: почему-то проскакивает строчку Рез = опер.дебет.субконто(1); хотя условие Если Опер.Дебет.Счет = "43" Тогда выполняется.
Подскажите пож-та, где ошибка???

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
13 - 12.03.2009 - 12:22
+(12) неправильно написала, вместо:
В печ.форме вместо <Опер.ПредставлениеПроводки(1)>, написала <вывод>
читать:
В печ.форме вместо <Опер.ПредставлениеПроводки(1)>, написала <рез>

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
14 - 13.03.2009 - 05:00
up!

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
15 - 13.03.2009 - 06:09
up!!

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
16 - 13.03.2009 - 07:00
Ну может быть, кто-нибудь посмотрит все-таки...!!!
Помогите пожалуйста!!!
http://slil.ru/27114981

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

Melena
17 - 13.03.2009 - 08:35
Опер.Дебет.Счет = "43"  ???
Опер.Дебет.Счет =СчетПоКоду("43")

Re: КарточкаСчета - убрать в печ.форме вывод субконто ВидыНоменклатуры...

deefm
18 - 13.03.2009 - 10:19
(17) СПАСИБО!!!
К списку тем 1 > К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« Подскажите, каким документов в бух седлать перенос со счета 07 на 08? Как перевести учет яиц из тыс.шт. просто в штуки »
© 2009 Форум 1С: Одинэс.Ру