Получить в модуле документа его движения - для "Сторно"

Форум 1С: Одинэс.Ру

Найти!

Получить в модуле документа его движения - для "Сторно"

eloha
16.02.2009 - 07:35
Нужно для документа просмотреть его движение по регистрам.
Сделана процедурка в глобальном модуле, которая возвращает нужное значение, обращения к ней - из модулей документов,  понятно, что ДО очистуи движений по регистрам:
 
  Функция ПолучитьЗначИзРегистра(Конт, ВидРегистра) Экспорт
      Рез = 0;
      Рег = СоздатьОбъект("Регистр." + ВидРегистра);
      Если Рег.ВыбратьДвиженияДокумента(Конт) = 1 Тогда
  Пока Рег.ПолучитьДвижение()=1 цикл
      Рез = Рег.<здесь то что нужно>;
      Прервать;
  КонецЦикла;
      КонецЕсли;
      Возврат Рез;
  КонецФункции
 
Работает замечательно для всех документов, кроме Сторно. Он сам себя не видит.
Пробовала в процедурке заменить на запрос - результат тот же.
Что, документ Сторно - особый?
К списку тем К списку форумов

Интересные темы

odines.ru
21.10.2020 - 15:24
Смотри также:
Доступ по Оле на БД-Сервер, приемник - на локальном ПК. Выскакивает сообщение "Сервер занят!"
Отчет о прибылях и убытках Бухгалтерия 7.7
Таблица значений - свертка

Re: Получить в модуле документа его движения - для "Сторно"

Ёпрст
1 - 16.02.2009 - 07:48
(0) Вызываешь из Модуля документа в ОбработкаПроведения ?
Тогда поди у всех документов поди снята галка - автоматическое удаление движений и в коде стоит ОчиститьДвижения для всех регистров... а вот в Сторно твоём - стоит. Вот и движений старых нема ужо :)

Re: Получить в модуле документа его движения - для "Сторно"

eloha
2 - 16.02.2009 - 08:10
(1) Ну ё-п-р-с-т! Точно!
Стоит Автоматическое удаление движений!
Спасибо и доброго здоровьичка!
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« как в ЗАПРОСе использовать результат Функции в Условии? Подрядчик 1.4 Не устанавливается драйвер ключа под Висту »
© 2009 Форум 1С: Одинэс.Ру