Как встроить отсчет времени в форму

Форум 1С: Одинэс.Ру

Найти!

Как встроить отсчет времени в форму

Маус
13.07.2009 - 10:54
На форме имеется счетчик времени (тестовое поле с функцией).
В глобальном модуле есть ОбработкОжидания(), которая это значение формирует.
Как сделать, чтобы счетчик времени в форме отображал изменение энтого времени?
 
Счетчик отображает, только когда локальные переменные меняются, а изменились глобальные - не меняет. Что делать?
К списку тем 1 > К списку форумов

Интересные темы

odines.ru
20.10.2020 - 03:34
Смотри также:
переход на графу наименование в справочнике
УРИБ
Проблемы - запрет редактирования формы и перебор документов в журнале

Re: Как встроить отсчет времени в форму

Маус
5 - 13.07.2009 - 11:23
Код простой:
На форме есть Текстовое поле с функцией Функция1().
 
В модуле формы есть функция:
Функция Функция1()
    Возврат глПеременная1;
КонецФункции
 
В глобальном модуле есть процедура
Процедура ОбработкаОжидания()
    глПеременная1 = 1;
КонецПроцедуры
 
Очень хочется, чтобы Функция1() в форме вызывалась каждый раз, когда меняется глобальная переменная. Как это сделать?

Re: Как встроить отсчет времени в форму

Маус
6 - 13.07.2009 - 11:24
3-user1C >О круто!

Re: Как встроить отсчет времени в форму

Маус
7 - 13.07.2009 - 12:29
2-Reaper >Спасибо! Форма.Обновить() вставил - все заработало!
3-user1C >Отличный набор для размышлений!
 
П.С. _getPerformanceCounter - ух ты!

Re: Как встроить отсчет времени в форму

vS_spb
8 - 13.07.2009 - 13:44
жэсть... ты какой-то новый маус, не тот, который 4 года назад был? :)

Re: Как встроить отсчет времени в форму

Маус
9 - 13.07.2009 - 14:18
8-vS_spb >моему нику меньше года;))), про старого Маус ничего не слышал, свой ник взял от названия родной фирмы (ООО Маус Хауз, Белгород, since 2005 year) На форуме стаж 4 года, но был под другим ником (нескажу).

Интересные темы

odines.ru
20.10.2020 - 03:34
Смотри также:
v7: Убрать пустые значения в запросе.
Подскажите конфигурация по управлению погрузками и доставками (под платформу 7.7)
КУДиР для ЕСХН

Re: Как встроить отсчет времени в форму

drums2004
10 - 13.07.2009 - 14:22
Что .. под старым ником набарагозил ? :)

Re: Как встроить отсчет времени в форму

Маус
11 - 13.07.2009 - 14:27
10-drums2004 >То был чужой ник, да и я был молодым;)))...

Re: Как встроить отсчет времени в форму

Чучундер
12 - 13.07.2009 - 23:21
ну раз Мыша вставило, то вот тебе еще, пачитай:
- http://www.infostart.ru/blogs/61/
- http://infostart.ru/blogs/987/
- http://www.infostart.ru/projects/1969/

Re: Как встроить отсчет времени в форму

который не честный
13 - 14.07.2009 - 04:35
Кстати, обработу ожидания можно и не в глобальном запускать
Процедура Сформировать()
Сообщить(1);
КонецПроцедуры
 
Процедура ПриОткрытии()
Форма.ОбработкаОжидания("Сформировать",5);
КонецПроцедуры

Re: Как встроить отсчет времени в форму

pit
14 - 14.07.2009 - 05:02
а чучундер все свою помойку хвалит....
 
P.S. читать (13). много думать.....
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
« Очередная тема про рухнувшую базу. На какой конфе 7.7. можно вести несколько предприятий? »
© 2009 Форум 1С: Одинэс.Ру