Что можно сказать уникальному идентификатору объекта?

Форум 1С: Одинэс.Ру

Найти!

Что можно сказать уникальному идентификатору объекта?

Аба Хаба 2
17.07.2009 - 13:24
Вопрос вот в чем.
Можно ли по вот таким уникальным идентификаторам что-нибудь сказать о дате создания объектов, машин с которых они были созданы, авторе? Что в них хранится. Естественно, можно будет их сравнивать с другими идентификаторами в базе.
3a5faf41-477e-11de-8fef-001e0be90a30
3a5faf43-477e-11de-8fef-001e0be90a30
Ну или так: из чего они вообще состоят. Я нигде этого не могу найти. На каком-то форуме писалось, что сохраняется идентификатор сететевой карты, время и т.д. Но по какому правилу?
 
К списку тем К списку форумов

Интересные темы

odines.ru
20.07.2024 - 18:43
Смотри также:
Зарплата и Управление Персоналом, редакция 2.5 (2.5.13.5)
Начисление процентов в 1С Бухгалтерии. Бухгалтерский и налоговый учет.
Подскажите пожайлуста новичку

Re: Что можно сказать уникальному идентификатору объекта?

Михаил Козлов
1 - 17.07.2009 - 15:14
Вот как-то встретил:
Функция ДатаСозданияСсылки(Ссылка) Экспорт
Если НЕ ЗначениеНеЗаполнено(Ссылка) Тогда
  Момент=Дата(1,1,1);
  Попытка
    УИ=Строка(Ссылка.УникальныйИдентификатор());
    УИ=ВРег(СтрЗаменить(УИ,"-",""));
    Если Сред(УИ,13,1)="1" Тогда
      Значение16=ВРег(Сред(УИ,14,3)+Сред(УИ,9,4)+Сред(УИ,1,8));
      Цифры16="123456789ABCDEF";
      Значение10=0;
      Длина16=СтрДлина(Значение16);
      Для Ном=1 По Длина16 Цикл
        Значение10=Значение10+Pow(16,Длина16-Ном)*Найти(Цифры16,Сред(Значение16,Ном,1));
      КонецЦикла;
      Значение10=Значение10/10000000;
      Момент=Дата(1582,10,15,3,0,0)+Значение10;
    КонецЕсли;
  Исключение
  КонецПопытки;
  Возврат Момент;
иначе
  возврат("нет данных")
КонецЕсли;
КонецФункции

Re: Что можно сказать уникальному идентификатору объекта?

Аба Хаба 2
2 - 18.07.2009 - 06:12
интресно. спасибо!
А ещё в идентификатре забита модель (или номер) сетевого интерфеса и что-то ещё (пользователь наверно). последняя группа - идентификатор типа объекта, я так понимаю. Потому что последняя группа у всех документов этого вида - одинаковая.
Кто нибудь точно знает?

Re: Что можно сказать уникальному идентификатору объекта?

Аба Хаба 2
3 - 19.07.2009 - 09:40
люди, ну подскажите, плиз.
К списку тем К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« БП 1.6.16.6 Авансы по ЕСН Ищу хорошего тренера по 1С Предприятие 8.1 :-) »
© 2009 Форум 1С: Одинэс.Ру