Как изменить время документа?

Форум 1С: Одинэс.Ру

Найти!

Как изменить время документа?

lprihod
27.07.2009 - 07:19
Как правильно задать время у документа?
Такая конструкция не работает.
Процедура ИзменитьВремяУдокументов(Элемент)
Запрос = Новый Запрос(
"ВЫБРАТЬ
| Док.Ссылка
|ИЗ
| Документ.ПоступлениеТоваровУслуг КАК Док
|ГДЕ
| Док.СкладОрдер = &Склад
| И Док.Дата >= &НачДата
| И Док.Дата <= &КонДата
| И (НЕ Док.ПометкаУдаления)");
 
Запрос.УстановитьПараметр("Склад", ВыбСклад);
Запрос.УстановитьПараметр("НачДата", НачалоДня(НачПериода));
Запрос.УстановитьПараметр("КонДата", КонецДня(КонПериода));
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
 
Пока Выборка.Следующий() Цикл
 
мОбъект = Выборка.Ссылка.ПолучитьОбъект();
ФлИзменен = Ложь;
 
Сообщить(Выборка.Ссылка, СтатусСообщения.Информация);
НовоеВремя=Лев(Выборка.Ссылка.Дата,10)+" 00:00:00";
Сообщить(НовоеВремя);
Выборка.ссылка.Дата=НовоеВремя;
//Если ФлИзменен Тогда
Если мОбъект.Проведен Тогда
мОбъект.Записать(РежимЗаписиДокумента.Проведение);
Иначе
мОбъект.Записать();
КонецЕсли;
// //
//КонецЕсли;
//
КонецЦикла;
 
Сообщить("Завершено");
 
КонецПроцедуры
К списку тем К списку форумов

Интересные темы

odines.ru
24.02.2024 - 11:27
Смотри также:
Нажимаю проверку галочку - высвечивает сообщения об ошибках. Не успеваю посмотреть - как оно исчезает. Что я случайно на
Межотчетный период Бухгалтерия 8.1
Как изменить программно цвет в ячейке табличного документа

Re: Как изменить время документа?

roma n
1 - 27.07.2009 - 07:22
Выборка.ссылка.Дата=НовоеВремя;
Изменять надо Объект
Преобразования типов выкинь, не нужны они.
НоваяДата = НачалоДня(СтараяДата)

Re: Как изменить время документа?

lprihod
2 - 27.07.2009 - 07:26
А если нужно поставить конкретное время?
например 02:35:00

Re: Как изменить время документа?

roma n
3 - 27.07.2009 - 07:28
НоваяДата = НачалоДня(СтараяДата) + Часов*60*60+Минут*60+Секунд

Re: Как изменить время документа?

lprihod
4 - 27.07.2009 - 07:35
Спасибо!
К списку тем К списку форумов

Добавить новое сообщение

Ваше имя:
Тема сообщения:
Сообщение:
« построитель отчетов. итог по колонкам V8.1 Проблемы работы с Вистой 64 : тормозит. »
© 2009 Форум 1С: Одинэс.Ру