Новая 4-ФСС. Глюк в релизе 2.5.15

Форум 1С: Одинэс.Ру

Найти!

Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
09.07.2009 - 19:08
В новом релизе новая форма 4-ФСС, это конечно хорошо. Но зато теперь невозможно расшифровать ячейку. При нажатии на кнопку Расшифровка выходит ошибка:
{Отчет.РегламентированныйОтчет4ФСС.Форма.ФормаОтчета2009Кв2(3362)}: Метод объекта не обнаружен (ВывестиОтчетРасшифровку)
ЗаполнениеРегламентированнойОтчетностиПереопределяемый.ВывестиОтчетРасшифровку(ЭтотОбъект, ЭтаФорма);
 
Это бы нужно очень, есть какой-нибудь выход?
К списку тем К списку форумов
Google Adsense

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
1 - 09.07.2009 - 19:36
Нашел причину. В новом релизе процедура расшифровки заключена в блок:
 
#Если Клиент тогда
#КонецЕсли
 
Да и раньше у нас был файловый режим работы, а тут перешли на SQL.
 
Т.е. получается что у нас это условие не выполняется? Я вообще не особо понимаю эти инструкции препроцессору. Т.е. получается что данная процедура может выполняться только на стороне клиента, а при нашей настройке сети и 1С на самом деле вызов происходит на стороне сервера? В чем причина этого, в то что работа идет через Citrix, т.е. удаленно на сервере все запускают 1С.
Как бы понять это и что предпринять?

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
2 - 09.07.2009 - 20:18
Т.е. я понимаю, что в случае
#Если Клиент тогда
#КонецЕсли
 
блок будет выполняться лишь на стороне клиента.
 
Но как его заставить там выполняться? Почему это выполняется на стороне сервера, с чем связано?

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

МимохожийОднако
3 - 10.07.2009 - 04:17
А отладчик что показывает? Может не там ищешь?

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
4 - 10.07.2009 - 05:42
Отладчик так и показывает, доходим до вызова процедуры:
ЗаполнениеРегламентированнойОтчетностиПереопределяемый.ВывестиОтчетРасшифровку()
и пишет что метод не обнаружен. Хотя процедура ВывестиОтчетРасшифровку() есть и находится именно в общем модуле ЗаполнениеРегламентированнойОтчетностиПереопределяемый. Т.е. в конфигураторе по правой клавише мышки переходит на неё.
Но из-за того что сама процедура ВывестиОтчетРасшифровку() находится внутри условия:
#Если Клиент тогда
#КонецЕсли
 
то при выполнении не находит её.

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
5 - 10.07.2009 - 12:31
up

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
6 - 13.07.2009 - 04:22
up

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Ninon
7 - 13.07.2009 - 13:38
Сейчас на форуме разработчиков ответили на такой же вопрос:
надо в конфигурации у модуля "ЗаполнениеРегламентированнойОтчетностиПереопределяемый" установить флажлк "Клиент" (с помощью левой кнопки мыши)

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Антиквар
8 - 13.07.2009 - 19:46
(7) Конфигурация на поддержке, не хотелось бы снимать.
А 1С признает это как ошибку? Т.е. исправят в следующем релизе?
 
И можно пояснить смысл этих галочек? Если стоит только Сервер, то значит данный кусок кода будет выполняться на сервере. Если Клиент, то у клиента.
А если обе галки, что будет определять место выполнения? Т.е. вот в данном случае будет 2 галки. Т.е. вопрос в том, что конструкция
#Если Клиент тогда
проверяет где выполянется код? Либо она проверяет доступно ли выполнение на стороне клиента и если да (стоит галочка), то код выполняется.
 
И ещё вопрос: форум разработчиков - это где, на сайте 1С? Его можно как-то просматривать?

Re: Новая 4-ФСС. Глюк в релизе 2.5.15

Ninon
9 - 14.07.2009 - 04:11
(8)я просто случайно увидела такой же вопрос.
Там не говорят, когда исправят - там не регистрируют ошибки (это надо на хотлайн писать).
Его просматривать\писать можно, если у вас куплен "пакет разработчика" (к нему логан и пароль прилагается)
А выявленные ошибки и время исправления выкладывают на партнерском сайте users.v8.1c.ru
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»