А если вместо подразделения на 20, 26 сделать другое субконто?

Форум 1С: Одинэс.Ру

Найти!

А если вместо подразделения на 20, 26 сделать другое субконто?

Мисти
21.07.2009 - 16:33
Закрытие месяца типовое использоваться не будет.
Кто знает, где это еще может вылезти?
К списку тем 1 2 > К списку форумов
Google Adsense

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

roma n
50 - 23.07.2009 - 12:35
(49).... ээээх
ВЫБРАТЬ
ВложенныйЗапрос.Ссылка,
ВложенныйЗапрос.СуммаДокумента,
ВложенныйЗапрос.СуммаОборотКт
ИЗ
(ВЫБРАТЬ
РеализацияТоваровУслуг.Ссылка КАК Ссылка,
РеализацияТоваровУслуг.СуммаДокумента КАК СуммаДокумента,
ХозрасчетныйОбороты.СуммаОборотКт КАК СуммаОборотКт
ИЗ
Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.Обороты(&НачДата, &КонДата, Регистратор, Счет В ИЕРАРХИИ (&Выручка), , Организация = &Организация, , ) КАК ХозрасчетныйОбороты
ПО РеализацияТоваровУслуг.Ссылка = ХозрасчетныйОбороты.Регистратор
ГДЕ
РеализацияТоваровУслуг.Дата МЕЖДУ &НачДата И &КонДата
И РеализацияТоваровУслуг.Организация = &Организация
И РеализацияТоваровУслуг.Проведен) КАК ВложенныйЗапрос
ГДЕ
(НЕ ВложенныйЗапрос.СуммаДокумента = ВложенныйЗапрос.СуммаОборотКт)

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

Мисти
51 - 23.07.2009 - 13:39
Спасибо!!
50-roma n > Пожалуйста, еще один перевод на сегодня!! (последний!)
Вот в семерке можно в табличную часть вставить текст, а в колонке реквизита в формуле написать Валюта=Договор.ВалютаВзаиорасчета.
Во-первых, в 8 не знаю, как вставить текст, ну ладно, пусть будет реквизит, пригодится. Как и куда эту формулу вписать?

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

roma n
52 - 23.07.2009 - 13:54
В 8 все не так.
Добавляй колонку в ТабличноеПоле с нужным тебе типом
В событии ПриПолученииДанных() этого табличного поля доступна коллекция оформлений выводимых строк табличного поля (не путать с коллекцией строк источника данных!!!)
Перебирая эту коллекцию можно получить доступ к оформлению(не к данным !!!) конкретной ячейки этой строки. А оформление как-раз и рулит цветом, шрифтом, отображаемым текстом и картинкой.
То же можно сделать и в событии ПриВыводеСтроки()

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

Мисти
53 - 23.07.2009 - 14:02
"Перебирая коллекцию" - звучит заманчиво!
Сделала колонку "Валюта". Табличная часть называется "Начисления"
Как теперь сделать, чтобы в этой колонке всегда отображалась валюта взаиморасчетов реквизита той ж т.ч. по имени договор?
Пли-из, примерчик!

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

roma n
54 - 23.07.2009 - 14:14
Процедура НачислениПолученииДанных(Элемент, ОформленияСтрок)
Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
                ОформлениеЯчейки = ОформлениеСтроки.Ячейки.Валюта;
                ОформлениеЯчейки.УстановитьТекст(ОформлениеСтроки.ДанныеСтроки.Договор.ВалютаВзаиморасчетов.Наименование)
Если НЕ ООформлениеСтроки.ДанныеСтроки.Договор.ВалютаВзаиморасчетов = Константы.ВалютаРегламентированногоУчета.Получить() Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЖелтыйЗолотистый;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
=====
Как-то так

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

Мисти
55 - 23.07.2009 - 14:44
А куда эту процедуру вставить?
Есть список событий в свойствах формы, но вроде туда не подходит...
Валюта при этом не должна быть реквизитом документа, или все равно?

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

roma n
56 - 23.07.2009 - 15:05
событие не формы- табличного поля
реквизитом табчасти валюта быть не должна

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

Тёмный
57 - 23.07.2009 - 16:06
56-roma n >
55-Мисти >
в шаматы по переписке попробуйте сыграть - у вас навернака получится.
 
зы.
седня чет фаза у Луны злая. с утра заметил, но до вечера кусачесть осталась

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

zzz86
59 - 24.07.2009 - 10:15
(19)
нетиповой налоговый учет - это статья!!! =)

Re: А если вместо подразделения на 20, 26 сделать другое субконто?

Мисти
60 - 26.07.2009 - 06:25
56-roma n > Ты такой добрый! Можно я тебе 500 р. на телефон кину?
(плюс к общей благодарности, а то, как говорят, "спасибо в карман не положишь")
К списку тем 1 2 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»