Штрих-код

Форум 1С: Одинэс.Ру

Найти!

Штрих-код

Goodwin
26.06.2009 - 05:15
Каков вообще принцип действия сканера штрих кода? Каким образом при проведении по нему сканером позиция Номенклатуры попадает в документ? Можно ли штрихкодировать не только элементы справочника, но и документы?
К списку тем 1 > К списку форумов
Google Adsense

Re: Штрих-код

USSR
10 - 01.07.2009 - 12:29
а сам штрих-код формирую, например вот так, Вы сделаете по свему:
 
ШтрихКод = "1" +Сред(НомерДок, 4,2) + Прав(НомерДок,5) + Формат(ДатаДок - Дата("01.01.2005"),"Ч(0)4.0") +"0";
ШтрихКодСимв = ПолучитьШтрихКод(ШтрихКод);
 
Важно, чтобы код подчинялся правилам, например EAN-13, и Вы могли из него извлечь всю инфу по которой искать документ, либо писать штрихкод прямо в реквизит

Re: Штрих-код

Serginio
11 - 01.07.2009 - 13:17
Помотри
http://www.mista.ru/articles1c/hare/article.20.html

Re: Штрих-код

Программ1
12 - 01.07.2009 - 13:29
(11) Спасибо! Буду пробовать.

Re: Штрих-код

Serginio
13 - 01.07.2009 - 13:35
Если в номере докумена не содержаться кирилица
 
то например
 
Функция СформироватьКод39(ВыбРеализация,Знач суффикс="") Экспорт
        Если ВыбРеализация.Выбран()=1 Тогда  
Номер=СокрП(ВыбРеализация.НомерДок);
// Номер=Трим(Номер);
            Код=Формат(ВыбРеализация.ДатаДок,"ДГГГГММДД")+Номер;
Если ПустаяСтрока(Суффикс)=0 Тогда
    Код=Код+Суффикс;
КонецЕсли;
 
Стр=Code39Generate(код);
возврат Стр
КонецЕсли;
возврат "";
КонецФункции

Re: Штрих-код

USSR
14 - 01.07.2009 - 13:58
Блин, я привел готовый, несколько лет работающий код, а спасибо другому, за ссылку, по которой в принципе все тоже самое. И есть ли в этом мире хоть толика справедливости? ))

Re: Штрих-код

Serginio
15 - 01.07.2009 - 14:01
(14) а где же шрифты, Code39? (широчайшая улыбка)
А со справедливостью в нашем мире весьма сложно.

Re: Штрих-код

USSR
16 - 01.07.2009 - 14:03
я писал про EAN-13, его достаточно, шрифт EanGnivc из регл отчетности

Re: Штрих-код

Serginio
17 - 01.07.2009 - 14:19
Я кстати многими шрифтами пользуюсь. Нужно подбирать оптимальные размеры.
А то, что спасибо не говорят за бескорыстную помощь не есть правильно.

Re: Штрих-код

Чучундер
18 - 02.07.2009 - 00:23
http://www.infostart.ru/blogs/226/
http://www.infostart.ru/projects/4603/

Re: Штрих-код

Программ1
19 - 02.07.2009 - 05:17
(10) Спасибо! Буду разбираться.
(17) Я стараюсь всегда быть вежливой. Извините.
А за помощь и участие - просто огромнейшее спасибо.
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»