Документ Недолжен попадать 2 раза

Форум 1С: Одинэс.Ру

Найти!

Документ Недолжен попадать 2 раза

MisterVova
29.07.2009 - 07:12
Ит.ИспользоватьСубконто(ВидыСубконто.Комплектующие);//,спр.текущийЭлемент().Владелец,2);
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
Ит.ИспользоватьСубконто(ВидыСубконто.Коды,плата,2);  
 
Ит.ВыполнитьЗапрос(Дата1,Дата2,СчетПоКоду("211"),,,,"Операция");  
 
Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1)=1 Цикл
 
Ит.ВыбратьСубконто(2);
Пока Ит.ПолучитьСубконто(2)=1 Цикл    
МестаХранения=Ит.Субконто(2);
Ит.ВыбратьСубконто(3);
Пока Ит.ПолучитьСубконто(3)=1 Цикл
Ит.ВыбратьПериоды(1,0);
Пока Ит.ПолучитьПериод()=1 Цикл    
 
Тзя.НоваяСтрока();
Дк=Ит.Операция.Документ.ТекущийДокумент();
Тзя.Дата=Дк.ДатаДок;
Тзя.Доки=Дк;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;        
 

 
Как это отсечь?  без поиска в таблицеЗначений
К списку тем К списку форумов
Google Adsense

Re: Документ Недолжен попадать 2 раза

Reaper
1 - 29.07.2009 - 07:14
сверни

Re: Документ Недолжен попадать 2 раза

roma n
2 - 29.07.2009 - 07:15
Сверни ТЗ
Или не разворачивай итоги по субконто

Re: Документ Недолжен попадать 2 раза

MisterVova
3 - 29.07.2009 - 07:27
Зделал так
Тзя.Свернуть("Дата,Позиция,Доки,МестаХранения,Содержание,Аппарат,ИграДо","");
Тзя.Сортировать("Позиция");
 

посиба получилось
думал лучше буде средствами Бух...Итогов это зделать
 

Re: Документ Недолжен попадать 2 раза

Sk0rp
4 - 29.07.2009 - 09:44
Тзя.Свернуть("Дата,Позиция,Доки,МестаХранения,Содержание,Аппарат,ИграДо","");
 
проект по автоматизации новых игровых зон? :)

Re: Документ Недолжен попадать 2 раза

Брухо
5 - 29.07.2009 - 10:22
roma n если можно помогите http://forums.kuban.ru/forum/viewtopic_new.php?t=505685&all=all

Re: Документ Недолжен попадать 2 раза

MisterVova
6 - 31.07.2009 - 10:18
переделал отчет через запрос
Просче стало
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»