Подчинённые документы

Форум 1С: Одинэс.Ру

Найти!

Подчинённые документы

MisterVova
31.07.2009 - 07:37
Процедура ПриЗаписи()  // это мы призаписи Документа Основания
 
Пока Парам>=ДатаСМин Цикл
Докум=СоздатьОбъект("Документ.РезультатЗаДень");
Докум.Новый();
Докум.ДатаДок=Парам;
Докум.ДокументОснование=ТекущийДокумент();
Пока ТабЗн.ПолучитьСтроку()=1 Цикл
Докум.НоваяСтрока();
Докум.Зал= ЗалНаНачалаДня(ТабЗн.Аппарат,Парам);  
Докум.Аппарат   = ТабЗн.Аппарат;
Докум.ЗаправленоРазн = ТабЗн.ЗаправленоРазн;
Докум.СнятоРазн       = ТабЗн.СнятоРазн;
Докум.Результат       = ТабЗн.Результат;
Докум.СнятоЧистыйВЛеях = ТабЗн.СнятоЧистыйВЛеях;
Докум.ДжекПот          = ТабЗн.ДжекПот;//ТабЗн.ДжекПотРазн/Коэф;
Докум.ЗаправленоЧистыйВЛеях = ТабЗн.ЗаправленоЧистыйВЛеях;
ТабЗн.КвоДней=ТабЗн.КвоДней-1;
КонецЦикла;
Докум.Записать();
Докум.Провести();
.....
КонецПроцедуры  
 

КонецЦикла;
К списку тем 1 > К списку форумов
Google Adsense

Re: Подчинённые документы

Uho
1 - 31.07.2009 - 07:42
очередная нетленка?
порадовало:
Докум.Провести();
.....
КонецПроцедуры  
 
 
КонецЦикла;

Re: Подчинённые документы

MisterVova
2 - 31.07.2009 - 07:42

Вопросик Почему Документ Основание не видит подченённых документов после записи 1 записи
я их не могу выбрать а значит и не могу удалить
 
после открытия формы повторно  всё работает как часики  
он пересоздаёт себе подченённых и всё ок
 
 
 

Re: Подчинённые документы

MisterVova
3 - 31.07.2009 - 07:43
Если Выбран()=1 Тогда
Док=СоздатьОбъект("Документ");
Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид()<>"РезультатЗаДень" Тогда
Продолжить;
КонецЕсли;
Док.Удалить(1);
КонецЦикла;
КонецЕсли;

Re: Подчинённые документы

Uho
4 - 31.07.2009 - 07:43
а где Парам уменьшается, судя по всему в ЗалНаНачалаДня()?
или это у тебя вечный цикл (хотя, учитывая (1), циклом тоже можно назвать с натяжкой)?

Re: Подчинённые документы

MisterVova
5 - 31.07.2009 - 07:44
1-Uho >
ну ты понял

Re: Подчинённые документы

Uho
6 - 31.07.2009 - 07:45
такая каша
ЗЫ. (3) удалять элементы выборки в цикле по ней надо грамотно

Re: Подчинённые документы

MisterVova
7 - 31.07.2009 - 07:47
4-Uho >
 
там концовка урезанна
 
КонецЦикла;
Докум.Записать();
Докум.Провести();
Парам=Парам-1;
КонецЦикла;
КонецЕсли;
глУстановитьВремяДокумента(Контекст);
КонецПроцедуры

Re: Подчинённые документы

MisterVova
8 - 31.07.2009 - 07:48
3-MisterVova >  идет до    0-MisterVova >

Re: Подчинённые документы

MisterVova
9 - 31.07.2009 - 07:51
6-Uho > всё удаляется четко
если документ был перезаписн то есть если  уже был записанн
а если при первой записи то документ основание не видит своих подчинённых
а у продинённых есть документ основание

Re: Подчинённые документы

MisterVova
10 - 31.07.2009 - 07:56
походу надо сначала записать потом делать документ основание

Re: Подчинённые документы

pit
11 - 31.07.2009 - 07:57
щас Дятел придет ... стучать будет... по башке, по башке....

Re: Подчинённые документы

MisterVova
12 - 31.07.2009 - 08:12
11-pit >
 

//*******************************************
Процедура Сформировать()    
Вопрос("щас Дятел придет",2);
а=Вопрос("стучать будет",2);
    
Пока а<а+1 Цикл
Сообщить("... по башке");
КонецЦикла;
КонецПроцедуры

Re: Подчинённые документы

Uho
13 - 31.07.2009 - 08:15
12-MisterVova > с головой дружишь?

Re: Подчинённые документы

MisterVova
14 - 31.07.2009 - 08:17
Пока ESC работает

Re: Подчинённые документы

MisterVova
15 - 31.07.2009 - 08:22
//Сразу после
Процедура ПриЗаписи()  
//написал  
Записать();
заработало

Re: Подчинённые документы

MisterVova
16 - 31.07.2009 - 08:28
11-pit > Это тибе пит
 
Процедура Сформировать()    
Вопрос("щас Дятел придет",2);
а=Вопрос("стучать будет",2);
    
Пока а<?(а=а,а+а,а-а) Цикл
Сообщить("... по башке");
КонецЦикла;
КонецПроцедуры

Re: Подчинённые документы

pit
17 - 31.07.2009 - 08:41
купил колы и чипсов.
Сижу, сматрю кено от мистера вовы...
 

. . . . . . . . . . . . . . . . ‘^. . . . . . . ^’. . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . . . . .| \ ,~~~~,/ .\ . . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . . . , ‘ . % . . . . . . .’, . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . . , - - . . . . . . . . . . ,\. . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . .( ‘-‘ ) . . . . . . . . . . . .’\ . . . . . . . . . . . . . .
. . . . . . . . . . . . . . .’-- __-‘ . . . . . . . . . . .\ . . . . . . . . . . . . .
. . . . . . . . . . . . , (_____. . . . . . . . . . . . . .’-, . . . . . . . . . . .
. . . . . . . . . . . ./ . . . . . . . . . . . . . . . . . . . . . .| . . . . . . . . . . .
. . . . . . . . . . ./ . . . . . . . . . . . . . . . ‘,. . . . . .,/ . . . . . . . . . . .
. . . . . . . . . . |. . . . . . . . . . . . . . . . .\, . . .,-‘ . ‘,. . . . . . . . . . .
. . . . . . . . . . .\ . . . . . . . . . . . . . . . ./ . . / . . . . |. . . . . . . . . .
. . . . . . . . . . ./ \,,,/. . . . . /. . . . . . . .”” . . . . . .j . . . . . . . . . .
__________|. . . . . . . . .| . . . . . . . ,_______j___________
. . . . . . . . . . .’-, . . . . . . .’-, . . . . ./ . . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . ‘,. . . . . . ./ . . .,-‘ . . . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . ‘,_, _/. . .’,_ ,-‘ . . . . . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . .”” . . . . . .”” . . . . . . . . . . . . . . . . . . . . .
 

Re: Подчинённые документы

КвазиСпец
18 - 31.07.2009 - 08:43
Блин, хаксер отдыхает :)

Re: Подчинённые документы

USSR
19 - 31.07.2009 - 09:47
Мдя .... Умора ...

Re: Подчинённые документы

MisterVova
20 - 31.07.2009 - 10:00
17-pit >
Обязательно отвечу

Re: Подчинённые документы

LuckyIzja
21 - 31.07.2009 - 12:11
ПятнеЦЦо?

Re: Подчинённые документы

Marlboro
22 - 31.07.2009 - 12:29
Ща Vova для вывода картинки (17) программный код опубликует

Re: Подчинённые документы

Vacony
23 - 31.07.2009 - 12:45
Ну да, просто в Сообщить() будет негламурненько...

Re: Подчинённые документы

Дятeл
24 - 31.07.2009 - 12:51
11-pit > тук тук тук

Re: Подчинённые документы

USSR
25 - 31.07.2009 - 12:56
Вова снимет сериал "Похождения бравого не Бреда Пита"

Re: Подчинённые документы

Marlboro
26 - 31.07.2009 - 13:02
(25) Бред Пита... Сильно.

Re: Подчинённые документы

pit
27 - 31.07.2009 - 13:56
24-Дятeл > Смотрю я на тебя....
 
..................___ ............................................................................................................
..................',_`""\..................---,............................................................................
........................\......:-""``/`........| ..........................................................................
..........................`;'..........//`\....../ ..........................................................................
........................../......__..........|......(' ........................................................................
........................|_..../O)\..........\....`)..\ ....................................................................
......................_/-..........`............`"`....|`-.. ............................................................
................-=;..`..................................../......`- ..........................................................
............/o..o..\......,_,........................................' ......................................................
............L.._.._;_..-'................................................`'- ..............................................
................`'-..`..........................'..................................`'- ......................................
........................`....................'................................................`- ................................_
............................'-.._....-'............................................................' ........................
..................................\........................................................................`\ ......................
....................................|..........................................................................\ ....................
....................................|........|..................................................................;......_.. ..................
....................................\........|......................|..........................................|-..(( ..................
......................................;......\....................../......../................................|-..`\) ..................
......................................|..'....;................../........|..................................|(_)..) ..................
......................................|......\..\............../`........|..................................;'--' ..................
........................................\......'..\......../`............|................................/ ..................
..........................................|....../`|....;................\............................../ ..................
..........................................|....|....|....|-.._............'..........................' ..................
........................................../....|....|....|__..`'---"_;'-..............-'..................
........................................//__/..../....|..........-'``.........._..-'` ..................
....................................jgs..........//__/......//___..--''` ....................
 

Re: Подчинённые документы

Дятeл
28 - 31.07.2009 - 14:00
27-pit > отойди от зеркала

Re: Подчинённые документы

NIC001
29 - 31.07.2009 - 14:48
27-pit >
28-Дятeл >
Реальные кабаны!

Re: Подчинённые документы

pit
30 - 31.07.2009 - 14:55
29-NIC001 > подумал и написал .... маслом.... твой портрет....
сливочным...
 

|. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
|. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
|. . . . . . . . . . . . . . ._______.~~~~~~~. . . . . . . . . . . . . .
|. . . . . . . . . . . . . /’ . . . . . . . . . . . . . . . .\ . . . . . . . . . . . .
|. . . . . . . . . . . . / ’ \ . . . . . . . . . . . . . . . . \ . . . . . . . . . . .
|. . . . . . . .__--` \ ( ) ‘ \. . . . . . .’ ’ ’. . . . /‘. . . . . . . . . . . .
|. . . . . . .| . . . . . . . . . . . . . . . . . . . ;. . ./ . . . . . . . . . . . . .
|. . . . . . . \ . .} . . . . . . . . . . . . . . ./ . . . ‘\. . . . . . . . . . . . .
|. . . . . . . . ./. . . . . . {. . . . . . /’. . . . . ‘\. . .\ . . . . . . . . . . .
|. . . . . . . .{----------‘. . . . .;’ . . . . . . . .‘;. . .’| . . . . . . . . .
|. . . . . . . . .\. . . . . . . . : . . .| . . . . . . . . . \. . . . |. . . . . . . .
|. . . . . . . . . .’\______/ . . . |. . . . . . . . . . .| . . . . |. . . . . . .
|. . . . . . . . . . /. . . . . . . . . .| . . . . . . . . . . . |. . . . . .| . . . . .
|. . . . . . . . . ;. . . . . . . . . .|. . . . . . . . . . . .| . . . . . . . | . . . .
|. . . . . . . . . |. . . . . . . . .| . . . . . . . . . . . | . . . . . . . . . | . . .
|. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
 

Re: Подчинённые документы

NIC001
31 - 31.07.2009 - 15:17
30-pit >
Спасибо, мне очень понравилось! Я на нём такой симпатичный!

Re: Подчинённые документы

pit
32 - 31.07.2009 - 15:27
я рад за себя - мне удалось!!!!

Re: Подчинённые документы

MisterVova
33 - 31.07.2009 - 19:43
30-pit >чето то твой запрос ошибку выдаёт

Re: Подчинённые документы

pit
34 - 31.07.2009 - 19:54
какой запрос?

Re: Подчинённые документы

user1C
35 - 31.07.2009 - 20:01
тяпница, харош вестись...
ЗЫ
mr. vovu, фтопку

Re: Подчинённые документы

МимохожийОднако
36 - 01.08.2009 - 03:16
настала тяпница - отключи отладчик!©
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»