Как в 8-ке выбрать ВСЕ документы?

Форум 1С: Одинэс.Ру

Найти!

Как в 8-ке выбрать ВСЕ документы?

Umka2008
31.07.2009 - 10:24
Типа в 77 было так:
 
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
     Сообщить(Док);
КонецЦикла;
 
А в 8-ке надо по каждому виду отдельно что ли?
К списку тем 1 > К списку форумов
Google Adsense

Re: Как в 8-ке выбрать ВСЕ документы?

Umka2008
1 - 31.07.2009 - 10:31
Ап

Re: Как в 8-ке выбрать ВСЕ документы?

angro
2 - 31.07.2009 - 10:32
ага или обходом метаданных

Re: Как в 8-ке выбрать ВСЕ документы?

Umka2008
3 - 31.07.2009 - 10:35
Зашибись. А что так по-уродски? Например хочу провести все подряд.
А получится сначала тока Поступления, потом тока Реализации ...

Re: Как в 8-ке выбрать ВСЕ документы?

angro
4 - 31.07.2009 - 10:41
:)
Пусть безумная идея,
Не решайте сгоряча!
Вызывайте нас скорее
Через доку-главврача.
С уваженьем. Дата, подпись.
Отвечайте нам, а то,
Если вы не отзоветесь,
Ох, мы напишем в "Спортлото"!

Re: Как в 8-ке выбрать ВСЕ документы?

angro
5 - 31.07.2009 - 10:44
(3) запрос сконструируй и по дате отсортируй

Re: Как в 8-ке выбрать ВСЕ документы?

Umka2008
6 - 31.07.2009 - 10:44
это к чему?

Re: Как в 8-ке выбрать ВСЕ документы?

angro
7 - 31.07.2009 - 10:44
(6) смешное возмущение

Re: Как в 8-ке выбрать ВСЕ документы?

Umka2008
8 - 31.07.2009 - 10:48
короче просто перебора не существует ... Ладно придется мудрить с запросом

Re: Как в 8-ке выбрать ВСЕ документы?

angro
9 - 31.07.2009 - 10:50
(8) в принципе если тебе нужны не все, а какие-то конкретные, то можно выбрать по журналу

Re: Как в 8-ке выбрать ВСЕ документы?

angro
10 - 31.07.2009 - 10:51
Запрос = Новый Запрос;
    ФлагПервыйВход = Истина;
    Запрос.Текст = "ВЫБРАТЬ ВложенныйЗапрос.Ссылка ИЗ (";
    Для каждого Док из Метаданные.Документы Цикл
        Если НЕ ФлагПервыйВход Тогда
            Запрос.Текст = Запрос.Текст + " ОБЪЕДИНИТЬ ВСЕ ";
        КонецЕСли;
        ФлагПервыйВход = Ложь;
        Запрос.Текст = Запрос.Текст + " ВЫБРАТЬ Ссылка ИЗ Документ." + Док.Имя + " ГДЕ НачалоПериода(Дата, ДЕНЬ) = &Дата ";
    КонецЦикла;
    Запрос.Текст = Запрос.Текст + ") КАК ВложенныйЗапрос УПОРЯДОЧИТЬ ПО ВложенныйЗапрос.Ссылка.Дата";
    Запрос.УстановитьПараметр("Дата", НачалоДня(ТекущаяДата()));
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        ДокСсылка = Выборка.Ссылка;
    КонецЦикла;

Re: Как в 8-ке выбрать ВСЕ документы?

Umka2008
11 - 31.07.2009 - 11:11
Пасиб

Re: Как в 8-ке выбрать ВСЕ документы?

Lexusss
12 - 31.07.2009 - 11:23
Восстановлением последовательности пользуются только лохи...
К списку тем 1 > К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»