Шедевр кода в бюджетке 633. Студенты жгут.

Форум 1С: Одинэс.Ру

Найти!

Шедевр кода в бюджетке 633. Студенты жгут.

Alco
30.07.2009 - 10:03
Документ ОС_ПринятиеКУчету модуль документа:
 
Если СпособНачисленияАмортизации="3" Тогда
Если СрокПолезногоИспользования=0 Тогда
Сообщить("Не задан срок полезного использования ОС","!!");
СтатусВозврата(0);
ОК=0;
КонецЕсли;
Иначе
Если (БалансоваяСтоимость>ВторойПределОС) и (ХозОперация <> 8) Тогда
Сообщить("Для ОС, стоимостью более "+ ВторойПределОС+" должен использоваться линейный способ начисления амортизации","!!");
СтатусВозврата(0);
ОК=0;
КонецЕсли;
КонецЕсли;                
 
СпособНачисленияАмортизации Тип значения - число.
 
Теперь конкурс: кто быстрее проведет документ с ОСом стоимостью более 20 000.
Такой же ляп во вводе остатков, корректировке амортизации и оприходовании излишков, только менее болезненный.
        
К списку тем К списку форумов
Google Adsense

Re: Шедевр кода в бюджетке 633. Студенты жгут.

Lexusss
1 - 30.07.2009 - 10:05
:-D

Re: Шедевр кода в бюджетке 633. Студенты жгут.

Reaper
2 - 30.07.2009 - 10:08
0-Alco > Напиши авторам письмо: "Граждане, вы не поверите, но в объектной модели Вашей платформы существуют Перечисления, которые помогут вам избежать путаницы с типами данных."

Re: Шедевр кода в бюджетке 633. Студенты жгут.

pit
3 - 30.07.2009 - 10:18
опять Mike филонит - палку поставил в шкаппп

Re: Шедевр кода в бюджетке 633. Студенты жгут.

СветикK
4 - 02.08.2009 - 06:55
а у нас эти "студенты" в почете и в цене, блин... все цены перебиты только студенты и работают а с опытом работы людей не надо ни кому волонтерством что ли занятся... (((

Re: Шедевр кода в бюджетке 633. Студенты жгут.

Mitrich
5 - 02.08.2009 - 07:31
(4) СветикK, золотце. Отложите в сторону кагорчик, съездите в отпуск.
Когда вы вернетесь - все будет нормуль, студенты уйдут обратно в институты на учебу, спрос появится. Да и переквалифицироваться "если вдруг" лучше начинать хорошо отдохнувшим.

Re: Шедевр кода в бюджетке 633. Студенты жгут.

bushd
6 - 02.08.2009 - 07:49
Бюджетка это вообще такой сильно сомнительный шедевр от 1С... Даже дело не только в коде. А как вообще реализован налоговый учет ОС к примеру. Нахрен спрашиваеться велосипед было выдумывать.

Re: Шедевр кода в бюджетке 633. Студенты жгут.

Пудель
7 - 03.08.2009 - 09:43
(6) Бюджетка - аккуратная и надёжная. Код не гениальный, да. Ляпы бывают.

Re: Шедевр кода в бюджетке 633. Студенты жгут.

Пудель
8 - 03.08.2009 - 10:51
(0) "Sent: Thursday, July 30, 2009 12:52 PM
Спасибо за сообщение. Ошибку исправим в следующем релизе 7.70.634.#*#"
К списку тем К списку форумов
Тема закрыта и находится в архиве.
Но Вы можете начать новую тему.
© 2009 Форум 1С: Одинэс.Ру
В основу сайта был положен архив форума «Территория 1С»